Unityで Android API level 29 のビルド

投稿者:

 google paly console でApi level 29の準備をしてねと言われたので、ビルドしようとしてひと手間かかったのでメモ。

 いずれUnityのバージョンが上がって、インストール時のAndroid SDKも新しいのになりそうなのでほっといても良かったような気もしますが、Unityのバージョンアップはしたくないというときのため。

 File > Build Settings > Player Settings > Player > Target API Level > API level 29

 これで対応するSDKがインストールされていればビルド成功しますが、インストールされていないと下図の失敗ダイアログが表示されます。

 Update Android SDK でアップデート成功すればよいのですが、私の場合は管理者権限が必要な場所にインストールされていたので、下図の失敗ダイアログが表示されて上手くいきませんでした。

 ということで手動でアップデートします。

Edit > Preferences を開きます

 開いたら External Tools の Android SDK がインストールされているパスをコピー

 コマンドプロンプトを管理者として実行

 cd コマンドで先ほどコピーしたパスに\tool\binをつなげて実行

 sdkmanager.bat "platforms;android-29" でインストール開始です。

 途中、確認がでてくるので「y」をいれてエンター。

 特に問題がなければ下のダイアログのようになって終了です。

 Android SDK のパス /platforms/android-29 というのがインストールされます。

返信を残す

メールアドレスが公開されることはありません。

4 + fourteen =